Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Help with RA and C&C Gold Installation

  1. #1

    Question Help with RA and C&C Gold Installation

    I'm getting two different error messages when trying to play these games

    When I double click the C&C Win95 Icon I get the error message

    "Error - Unable to allocate primary video buffer - aborting."

    When I double click the RA Win95 Icon I get the message

    "The procedure entry point SMapLS_IP_EBP_12 could not be located in the dynamic link library KERNEL32.dll."

    In both cases I followed the installation tutorial and everything seemed to work ok.

    Both exe files are running in compatibility mode.

    I've also installed the latest patch for both games, again following the instructions with no apparent problems.

    I'm using WinXP SP3

    Any help would be much appreciated.

    Thanks,

    Jonny

  2. #2

    Default

    For the C&C95 issue make sure you got the latest drivers for your graphics card and the latest DirectX installed.

    For your Red Alert issue; download and extract this archive into your Red Alert directory (overwrite the old files).

    You know when you have played too much C&C when you awnser everything with "affirmative" and "yes sir".

  3. #3
    Moderator Nyerguds's Avatar
    Join Date
    Apr 2006
    Location
    Flanders (Belgium)
    Posts
    533

    Default

    Odd. On RA1, Win95 compat mode and patch 1.08 are enough to fix that specific issue... you must've some SOMETHING wrong there...

    but yeah, install the 3.03 patch :P

  4. #4

    Default

    Installed 3.03 patch but now getting the same buffer allocation error for both RA and Gold/TD. The good folks at windows update tell me that all my drivers and software are up to date. Is there anything else I could try?

  5. #5

    Default

    If I remember correctly Windows Update doesn't update DirectX

    http://www.microsoft.com/downloads/e...D-85FC422D1388

    You know when you have played too much C&C when you awnser everything with "affirmative" and "yes sir".

  6. #6
    Junior Member
    Join Date
    Sep 2008
    Posts
    26

    Default

    When I double click the RA Win95 Icon I get the message

    "The procedure entry point SMapLS_IP_EBP_12 could not be located in the dynamic link library KERNEL32.dll."


    you need the recent thipx32.dll for red alert

  7. #7
    Moderator Nyerguds's Avatar
    Join Date
    Apr 2006
    Location
    Flanders (Belgium)
    Posts
    533

    Default

    You're kinda bumping old threads for no reason. The 3.03 patch fixes this too, and RA 3.03 doesn't use the thipx32.dll file anymore. Besides, if you're talking about WW's original fix, that dll was never for RA anyway, and just patching the game to 1.08 and then running it in Win95 compat mode even fixed that problem (WITHOUT removing LAN, I might add)

  8. #8
    Junior Member
    Join Date
    Feb 2010
    Posts
    4

    Default

    I get an

    Error: Unable to set video mode.

    All drivers are updated. I've done everything above.

    Now if i run the ra.exe, it works, except i have no sound.... (DOS version i think)
    Attached Images Attached Images  

  9. #9
    Moderator Nyerguds's Avatar
    Join Date
    Apr 2006
    Location
    Flanders (Belgium)
    Posts
    533

    Default

    run rasetup.exe, set the resolution to 640x480.

  10. #10
    Junior Member
    Join Date
    Feb 2010
    Posts
    4

    Default

    did that, still the same error.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •